Ponen coto a la vulnerabilidad Dirty Pipe en el kernel de Linux

 

Un error de gestión de memoria para la comunicación entre procesos permitía a los ciberdelincuentes controlar dispositivos ajenos, leer mensajes privados y comprometer aplicaciones bancarias.

Una vulnerabilidad grave en el núcleo del sistema operativo Linux permitía sobrescribir cualquier archivo sin los derechos de acceso correspondientes.

Bautizada como Dirty Pipe (CVE-2022-0847), ya ha sido subsanada por Linux y Google, dado que afectaba a todos los sistemas Linux a partir de la versión 5.8 del kernel y a los dispositivos Android que ejecutan aplicaciones no fiables.

El problema ha sido corregido mediante un ajuste del código fuente del kernel.

En sistemas no actualizados, un atacante sería capaz de ganar el control total de ordenadores o smartphones y, entre otras acciones, leer los mensajes privados de los usuarios o comprometer las aplicaciones bancarias.

El desarrollador de IONOS Max Kellermann fue quien descubrió este fallo a mediados de febrero después de recibir quejas de clientes sobre archivos corruptos.

Un error en la manera de gestionar la memoria para la comunicación entre distintos procesos, mediante las conocidas como tuberías, estaba detrás de Dirty Pipe, provocando que alguien con malas intenciones pudiesen saltarse los mecanismos de protección.

Share this:

Publicar un comentario

 
Copyright © LinuxClick. Designed by OddThemes